Xbox initiates but loses connection

Discussion in 'Windows Media Center' started by Ilbarbaro, Nov 24, 2005.

  1. Ilbarbaro

    Ilbarbaro Guest

    I'm trying to get my Xbox to connect to my HP Pavilion m7160n MCE system.
    When I first set it up a few days ago, it seemed to work ok. Now, it seems
    to affilliate successfully then the connection "unexpectedly" fails.

    MC, Security and System logs say nothing.

    Application logs states "AffConfirm RQ - Device
    {00000000-0000-0000-0000-0050F2532E6A} - Successfully affiliated" of type
    Information, but then has a follow on Warning entry related to source "Media
    Center Extender Services" that states: "VirusScan Enterprise: Blocked by
    behaviour blocking rule '_'.(from MCPASSPC IP 192.168.1.102 user SYSTEM
    running VirusScan Enter 8.0 OAS)"

    I looked through both the settings of my McAfee Virusscan and Desktop
    Firewall settings and can't figure out what setting or so called "behavior
    blocking rule" is blocking it or how to set up an exclusion.

    I disabled the Desktop Firewall and I still had the problem, so it must be a
    Virusscan behavior blocking rule as it suggests. In VS, I have several
    "Prevent ... Remote Creation, Modification, Access to Suspicious Startups,
    and Launching from the Temp Folder. I then disabled on access scanning and
    the blocking rules and I still have the problem.

    Additionally, the last 2 or 3 attempts show the successful "affiliation" log
    but no Warning log of the behavior blocking rule.

    Anybody know exactly what applications/services and related ports I should
    allow to avoid this problem. In no way do I want to simply turn off my
    security apps, especially since I do Xbox live from time to time.
     
    Ilbarbaro, Nov 24, 2005
    #1
    1. Advertisements

  2. Ilbarbaro

    Ilbarbaro Guest

    So I tried uninstalling from my MCE and it still doesn't work. This time I
    get several logs indicating communication attempts in this order:

    Error: Source: Media Center Extender Services; ERROR: Device Service
    Listener - TCP networking failed. Error code 0x80004005.

    Warning: Source: Media Center Extender Services; ERROR: TCPConnToMe -
    Device {00000000-0000-0000-0000-0050F2532E6A} - There was an error processing
    this request. Error code 0x80004005.

    Information: Source: Media Center Extender Services; AffConfirm RQ - Device
    {00000000-0000-0000-0000-0050F2532E6A} - Successfully affiliated.

    I again disabled the McAfee Desktop Firewall and still got this error.

    Dang, this is frustrating. The darn thing worked when I first installed it.
     
    Ilbarbaro, Nov 24, 2005
    #2
    1. Advertisements

  3. Ilbarbaro

    Ilbarbaro Guest

    One more thing ...

    From my MCE machine, I can ping my switch, my provider's DNS and Gateway
    machines, and even another laptop that's on the same local subnet, but I
    can't seem to ping my Xbox, even though I swear I could before.

    Additionally, the Xbox gets a valid IP via DHCP and connects to Xbox Live
    just fine.

    AAAAAAARGH!
     
    Ilbarbaro, Nov 25, 2005
    #3
  4. you mention a switch. do you have public IPs for all your computers
    from your ISP or are you behind a router (NAT)?

    --

    Barb Bowman
    MS Windows-MVP
    Expert Zone Columnist
    http://www.microsoft.com/windowsxp/expertzone/meetexperts/bowman.mspx
    http://blogs.digitalmediaphile.com/barb/
     
    Barb Bowman MVP-Windows, Nov 25, 2005
    #4
  5. Ilbarbaro

    Ilbarbaro Guest

    Ilbarbaro, Nov 25, 2005
    #5
  6. Barb Bowman MVP-Windows, Nov 25, 2005
    #6
  7. Ilbarbaro

    ilbarbaro Guest

    Barb,

    Sorry for the delay. I just haven't had time to focus on this frustrating
    ordeal.

    I have a Linksys BEFSR41 ver 2 Etherfast Cable/DSL Router with 4 port switch
    connected to my Comast Cable modem. I have no public static IPs on the
    inside. My MCE system is wired directly to this router/switch.

    In another room, I have a Linksys BEFW11S4 v2 WAP w/ 4 port switch which is
    connected to the BEFSR41 via the uplink port to make everything appear as on
    the same logical DHCPed subnet of 192.168.1.100-103. The Xbox (and a laptop)
    are wired directly to this switch.

    Since the last time I posted, I uninstalled McAfee Desktop Firewall ver 8.5
    from my MCE machine and reinstalled my extender software on my Xbox and on my
    MCE. Everything seems to install fine until I try to get the Xbox to
    communicate with my MCE then I run into the same old problem where the Xbox
    says it lost the connection. In my Event Viewer under Application events, it
    still detects a succesful affilitation, yet it doesn't work.

    I don't know if this helps, but I can ping the laptop connected to the
    BEFW11S4, but when I try to ping the Xbox (which is connected to the same
    BEFW11S4), the ping times out.

    Is there anything I can do? What could possibly be causing this? This is
    truly driving me nuts since this functionality is why I spent so much money
     
    ilbarbaro, Dec 4, 2005
    #7
  8. It's time to upgrade your Linksys gear. As I recall the BEFW11S4 has
    an uplink port to uplink a switch TO it. It wasn't desgined to be a
    switch itself. (and by the way, the WAN port on this is only 10 megs
    half duplex). the BEFW11S4 V2 is listed as NOT compatible with Xbox
    Live BTW even if you were to run it as a router.

    --

    Barb Bowman
    MS Windows-MVP
    Expert Zone Columnist
    http://www.microsoft.com/windowsxp/expertzone/meetexperts/bowman.mspx
    http://blogs.digitalmediaphile.com/barb/
     
    Barb Bowman MVP-Windows, Dec 4, 2005
    #8
  9. Ilbarbaro

    ilbarbaro Guest

    I'm still confused. Is there some specific missing capability? Do you know
    technically what is preventing MCE Ext from working correctly? My Xbox
    accesses Xbox Live without a problem. It even successfully affiliates w/ my
    MCE machine. I recently purchased a Netgear FR 114P Firewall/Router which I
    intended to swap out with the BEF. Will that work? Where can I find a list
    of compatible network devices?

    And lest I forget, thank you for all your help!
     
    ilbarbaro, Dec 5, 2005
    #9
  10. A network trace might help us debug this issue:

    1) download and install
    http://www.analogx.com/contents/download/network/pmon.htm (freeware) on the
    Media Center PC that's experiencing the problem
    2) go to the Windows desktop-->Start menu-->All
    Programs-->AnalogX-->PacketMon and start the "PacketMon" program
    3) press the "Start" button in the upper-right corner of PacketMon
    4) go through the motions on the Media Center and MCX device to reproduce
    the problem
    6) on the Media Center PC, press the "Stop" button on PacketMon
    7) go to the "File" menu of PacketMon and "Save As..." to a CSV file on your
    machine
    8) send the CSV file to msft_mcx at hotmail
     
    Rob Lehew [MSFT], Dec 6, 2005
    #10
  11. Ilbarbaro

    ilbarbaro Guest

    Will do. Putting the information together to send to you now. Thanks!!!
     
    ilbarbaro, Dec 8, 2005
    #11
  12. Ilbarbaro

    ilbarbaro Guest

    Rob,

    Any luck diagnosing the problem with all the information I sent you. I even
    tried to see if there was some way I could download an update to the Xbox
    Xtender software with no luck.
     
    ilbarbaro, Dec 13, 2005
    #12
  13. have you reconfigured your network to have only one single supported
    router? as I recall you had two routers chained together and were
    using one as a switch. I can't see in this thread that you
    reconfigured.

    --

    Barb Bowman
    MS Windows-MVP
    Expert Zone Columnist
    http://www.microsoft.com/windowsxp/expertzone/meetexperts/bowman.mspx
    http://blogs.digitalmediaphile.com/barb/
     
    Barb Bowman MVP-Windows, Dec 13, 2005
    #13
  14. Ilbarbaro

    ilbarbaro Guest

    Actually, I removed the old and supposedly non-compatible wired-only Linksys
    switch. I know have a Netgear FR114P firewall/router connected to the cable
    modem and serving as the gateway, dhcp assignor, and switch for the XBox and
    Laptop in the room it's in. Downstream (in the basement actually) I
    relocated the Linksys wireless WAP w/ 4 port switch such that its uplink port
    is connected to one of the Netgear's ports and the other 3 ports in the
    Linksys are filled with the other 3 cables that run to the other parts of my
    house.

    I think my big question is ... why would any of this matter? Did Microsoft
    make the SW especially proprietary in some way so only "certified" network
    devices will support the extender software or is MS using some unique
    implementation of standard networking protocols? Again, the Xbox does
    successfully affiliate with the MCE it just doesn't maintain the connection.

    After several weeks, this is simply frustrating as heck. It's not like I'm
    the only one with the problem. I see the 360s have had a similar program for
    which there is a SW update. Is there a SW update for the regular Xbox that I
    don't know about or should there be?

    I just don't understand how Microsoft can design this relatively simple
    capability to work in a broad spectrum of environments representative of
    their large and diverse customer base.
     
    ilbarbaro, Dec 13, 2005
    #14
  15. The BEFW11S4 v2 WAP w/ 4 port switch is not a WAP. It is a router
    that you are trying to use as a WAP. It is listed as incompatible as I
    already explained. I don't know what the issues are with the devices
    listed as incompatible. You need to replace it and not relocate it.

    http://www.xbox.com/en-US/live/connect/routerlanding.htm

    Incompatible Routers
    These routers have been found to be incompatible with
    Xbox Live.

    DLink Linksys Netgear SMC
    DI-754 BEFSR11 MR314 7004VBR
    DI-764 BEFW11S4 (v2) RP114 7004WFW
    NR041 RP334
    RT311
    RT314


    --

    Barb Bowman
    MS Windows-MVP
    Expert Zone Columnist
    http://www.microsoft.com/windowsxp/expertzone/meetexperts/bowman.mspx
    http://blogs.digitalmediaphile.com/barb/
     
    Barb Bowman MVP-Windows, Dec 13, 2005
    #15
  16. Ilbarbaro

    ilbarbaro Guest

    Barb,

    Thanks for the effort. First, I must have misunderstood you previously. I
    thought you were saying my Linksys wired only BEFSR41 was incompatible. WAP
    or no WAP, I can use the BEFW11S4 for wireless connections although that is
    not how my Xbox nor my MCE is connected. I'm probably misusing the term WAP.

    Additionally, is their a particular reason you focuson Xbox Live
    compatibility? What does Xbox Live have to do with connecting to my MCE
    machine on an internal only network? Regardless, Xbox Live has always worked
    just fine in my previous setup and my current setup for every game I play via
    XBox Live.

    I just need to get my Xbox to maintain it's connection to the MCE machine,
    regardless of Xbox live compatibility. What am I missing here?
     
    ilbarbaro, Dec 13, 2005
    #16
  17. Few questions:
    - How long are you able to stay connected for? Is it a constant amount of
    time each time you connect?
    - Does the time that you are disconnected correspond to the VirusScan
    warning in your event log?
    - Would you be willing to temporarily uninstall the McAfee software to
    eliminate it as a potential source of the problem?
     
    Todd Bowra [MSFT], Dec 14, 2005
    #17
  18. Ilbarbaro

    ilbarbaro Guest

    When I very first installed, I seemed to be able to maintain the connection
    although I didn't try playing with it for too long. Since then, in both my
    previous and current network set up, no luck. I know the Xbox successfully
    sees the MCE and affiliates because: 1. It doesn't prompt me with a new set
    up code, 2. The application event log says so. However, I get no actual
    connection. It affiliates and that is all.

    I also tried after uninstalling the McAfee Enterprise Desktop Firewall
    altogether and with McAfee VirusScan w/ Anti-Spyware Enterprise disabled.
    Still no go. However, I will try again with all McAfee apps uninstalled and
    let you know what happens. I did have some concerns around this which is why
    I originally asked if anyone knows exactly what ports, services, and
    applications need to be permitted between the two machines (not that it
    should be the root of the problem since I had MDFW uninstalled and it still
    didn't work.)

    Should I assume the logs I emailed to Rob didn't help?
     
    ilbarbaro, Dec 14, 2005
    #18
  19. you originally said your Xbox was connected to the BEFW11S4. You are
    trying to use the BEFW11S4 as a switch to uplink to another router. It
    is not designed to be used this way. Please connect the Xbox and the
    MCE computer to the same router that is connected to your broadband
    modem. what happens?

    I can't really help you further unless you remove the BEFW11S4
    completely to see if that resolves the issue. I think it will.

    --

    Barb Bowman
    MS Windows-MVP
    Expert Zone Columnist
    http://www.microsoft.com/windowsxp/expertzone/meetexperts/bowman.mspx
    http://blogs.digitalmediaphile.com/barb/
     
    Barb Bowman MVP-Windows, Dec 14, 2005
    #19
  20. Ilbarbaro

    ilbarbaro Guest

    Barb,

    That's a bit easier said than done since the Xbox is in the downstairs
    living room and the MCE is in an upstairs office. To be accurate the BEFSW11
    is serving as a router for the 3 other network segments in the to the Netgear
    Firewall/Gateway. The current configuration (and the previous) works fine
    for every single networking function (web, email, file sharing, print
    serving, Xbox Live, etc.) accept for MCEX. I can even install the Xbox
    Extender successfully and, upon start up, it will affiliate successfully, it
    just doesn't maintain it.

    I have removed all of my McAfee security SW to include DFW, AV, and ASpy.
    Same problem. I also tried using the Extender tools to update the Extender
    SW from my MCE. The connection is made but there doesn't seem to be an
    update available for Xbox Extender software.

    I'm not sure I can physically or logically set it up the way you suggest,
    but I'll try just to see if that is the problem. I am not trying to be a
    pain in the behind, but I simply want to know/understand what unique aspects
    are built into the way MCEX needs to communicate with MCE that prevents this
    router (or even network config) from working if all the machines are on the
    same logical network subnet. What is it that is so proprietary that this (or
    any) router/switch can't pass the packets back and forth, especially since
    even Xbox Live works fine. Can anyone on the team explain this to me?

    I'll let you know if I have any luck. It really should work more simply
    than this.
     
    ilbarbaro, Dec 15, 2005
    #20
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.