XCOPY Insufficient system resources problem.

Discussion in 'Windows Server' started by richard, Feb 23, 2007.

  1. richard

    richard Guest

    We are running a Windows 2003 Enterprise Edition server with SP1 (32-bit) and
    I have started getting a problem with a script we run to copy data from one
    folder to another ready for a backup.

    Basically the script uses the give seperate xcopy commands to move about
    20Gb spread over about 1000 or so files from one folder to another.

    We have started getting a message :-

    "File creation error - Insufficient system resources exist to complete the
    requested service."

    The xcopy command stops and it moves onto the next which usually works.

    I have had a look on the web and found about a problem with Windows 2000
    Server but cannot fine any details on this error with Windows 2003.

    Does anybody have any ideas what may be causing this? any help appreciated.

    Richard
     
    richard, Feb 23, 2007
    #1
    1. Advertisements

  2. richard

    Daniel Oxley Guest

    I have same some strange errors with xcopy in the past. I always use
    robocopy now and it works much better. With robocopy i have copied more
    than 20gb of data.
    Regarding your problem, I have no idea. sorry.
     
    Daniel Oxley, Feb 23, 2007
    #2
    1. Advertisements

  3. This problem has been around for quite some time when copying
    large trees with xcopy.exe. You can walk around it by using
    robocopy.exe or xxcopy.exe (which is downloadable from a
    number of sites).
     
    Pegasus \(MVP\), Feb 23, 2007
    #3
  4. richard

    richard Guest

    Thanks for the responses. I have changed the script to use robocopy and it
    seems to be fine now. Shame it outputs the percentage complete to the log
    file though !!
     
    richard, Feb 26, 2007
    #4
  5. robocopy has more switches than you can poke a stick at, including
    one to suppress the percentage output!
     
    Pegasus \(MVP\), Feb 26, 2007
    #5
  6. I also am having this problem when trying to copy files using the Windows
    Explorer. Both systems (target and source) are Windows Server 2003 R2 SP2.

    If I try and "push" files at the target, I get this error message:
    "Cannot copy <filename>: Insufficient system resources exist to complete the
    requested service."

    If I try and "pull" the files from the source, I get this error message:
    "Cannot copy <filename>: Not enough server storage space is available to
    process this command."

    I've searched the knowledgebase for both error messages and found solutions
    to either ancient NT products, some 2000 products, but nothing for Server
    2003.

    I'm fairly certain this limitation must still be in effect or have some
    bearing on my problem:
    http://support.microsoft.com/kb/833167/en-us

    Or less likely, something related to:
    http://support.microsoft.com/kb/259837/en-us

    Other details that might be pertinent:
    There is enough disk space on the destination server.
    I'm not using VSS in any way, but the service is enabled and runs as it sees
    fit.
    Antivirus is disabled on both sides, or enabled, but the messages are
    identical.
    I can move the files in other ways, such as, backing them up to a different
    media, and restoring that media to the destination.
     
    Chris Wilhelm, Jan 4, 2008
    #6
  7. Why would you use such a tortuous solution if robocopy.exe
    does it in one fell swoop?
     
    Pegasus \(MVP\), Jan 4, 2008
    #7
  8. Oh I wouldn't. I just want the problem fixed, or some discussion on how to
    fix it. It's not that I can't use robocopy, it's that I shouldn't have to.
    You know.. the principle.
     
    Chris Wilhelm, Jan 4, 2008
    #8
  9. Seeing that you're talking about principles: Microsoft have decided
    that xcopy.exe is superseded by robocopy.exe and that xcopy
    should no longer be used, presumably in view of the long-standing
    "System resources" problem.

    There is another reason why robocopy is preferable (other than
    it richer set of switches): It can deal with path+file names in excess
    of 255 characters. Xcopy can't.
     
    Pegasus \(MVP\), Jan 4, 2008
    #9
  10. After some poking around, I found this article, which isn't really related..
    but is, since it's a copying of files problem we have here, not specifically
    xcopy, but copy or even copying w/ windows explorer. They all error with the
    same message.
    The article is this:
    http://support.microsoft.com/default.aspx?scid=kb;EN-US;304101
    and suggests this:
    Registry setting 1
    1. Click Start, click Run, type regedit in the Open box, and then click OK.
    2. Locate and then click the following registry subkey:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory
    Management
    3. On the Edit menu, point to New, and then click DWORD Value.
    4. Type PoolUsageMaximum as the entry name, and then press ENTER.
    5. Right-click PoolUsageMaximum, and then click Modify.
    6. Click Decimal.
    7. In the Value data box, type 60, and then click OK.
    8. Quit Registry Editor.
    9. Restart your computer.

    Which indeed has rectified the issue.
     
    Chris Wilhelm, Jan 4, 2008
    #10
  11. Thanks for the update.

     
    Pegasus \(MVP\), Jan 5, 2008
    #11
  12. richard

    Ryan Guest

    Did you ever find a solution to your problem or did updating the
    PoolUsageMaximum fix this problem for you? I'm dealing with the same problem
    but changing PoolUsageMaximum hasn't fixed it.
     
    Ryan, Jun 20, 2008
    #12
  13. richard

    Ryan Guest

    Did you ever find a solution to your problem? I'm havnig the same problem now
    and don't have a clue what to do next. The best lead I've gotten is this:
    http://support.microsoft.com/default.aspx?scid=kb;EN-US;304101

    This doesn't seem to fix my problem. I'm thinking about further reducing the
    PageUsageMaximum to see if it helps on my system. Let me know if you find a
    solution.
     
    Ryan, Jun 20, 2008
    #13
  14. Hi all,

    I've been experiencing the "Insufficient system resources" problem for a
    long time, but always used other ways to circunvent it. But now I DO need to
    resolve it.

    Let me explain it: I work with server virtualization (through Virtual Server
    2005 R2 SP1), and it's common for me to have to copy huge VHDs files from one
    server to another. But the mentioned problem appears very often, and right
    now it's really driving me mad! Next weekend, I'll need to copy this kind of
    file fast, due to downtime window.

    I think I've tried every listed solution on internet and MS articles, and
    none of them helped me:
    - Xcopy didn't helped, and neither Rocobopy. Both shows me the same problem.
    - Changing IRPStackSize, PagedPoolSize, SystemPages or PoolUsageMaximum
    keys helped... with nothing! =P

    The solution that I've been using for this problem is copying the file with
    NTBackup. It works, but it's a extremelly slow solution, and I can't wait for
    so long.

    So please, anyone, is there a solution that really works? Or only on Windows
    x64 I'll finally see this damn problem resolved?

    Our servers are Dell PowerEdge 2800/2900, with Windows 2003 R2 SP2 x86, and
    they have, at least, 8Gb RAM. I'm pretty sure that they do have suficient RAM
    and free space while performing file copies.

    Thanks in advance ;)
    Eduardo Nazato
     
    Eduardo Nazato, Aug 15, 2008
    #14
  15. richard

    Ryan Guest

    Sorry I didn't post the solution when I found it. What worked for me was
    reducing the PagePoolMaximum to 30. I had tried reducing it to 60 but
    apperently that wasn't low enough. It only took me a month of calls to MS to
    get it resolved.
     
    Ryan, Aug 15, 2008
    #15
  16. Sorry, but even changing PagePoolMaximum didn't fixed the problem.
    Actually, changing it or the other listed keys stopped the error message
    from appearing, but made the copy seem to be hung (it never stops).

    As a (another) workaround, I'm using TeraCopy to copy these large files.
    http://www.codesector.com/teracopy.php
    It works very well, but in anyway solves the problem. Like said above:
    Windows Sever should do this "alone", and well.
     
    Eduardo Nazato, Sep 5, 2008
    #16
  17. You're replying to a thread created 18 months ago, on 23 February 2007. In
    the meantime Microsoft has officially deprecated xcopy.exe. The
    recommendation is to use robocopy instead.
     
    Pegasus \(MVP\), Sep 5, 2008
    #17
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.