XP 64 bit not showing all RAM

Discussion in 'Windows 64 Bit' started by dysonsphere, Nov 19, 2009.

  1. dysonsphere

    dysonsphere Guest

    I have a dual boot system running both XP and Ubuntu 64 bit.

    I have 8 GB of DDR2 RAM installed.

    XP shows 2.75 GB of RAM in System, while Ubuntu shows 7.8 GB.

    XP was showing almost 8 GB until just recently.

    I tried resetting the BIOS and that did not work. It was working fine on
    the default BIOS settings recently.

    Is there anything within the OS that needs to be tweaked in order for it to
    recognize all the RAM again?

    My hardware:

    Intel Pentium E5200 Dual Core @ 2.50 GHz
    XFX nForce 780i Motherboard
    8 GB DDR2 RAM (4 X 2 GB) Dual Channel.
    NVIDIA GeForce 9800 GT 1 GB video card.

    Thank you
     
    dysonsphere, Nov 19, 2009
    #1
    1. Advertisements

  2. dysonsphere

    Paul Shapiro Guest

    See if your BIOS has a setting to enable Memory Remapping, or some other
    name that sounds like it would be the same thing. Enabling this setting
    tells the bios to remap peripheral ram above the physical ram. Without that
    enabled, peripheral ram defaults to the top of the 4GB range, limiting
    available ram to whatever is left below that. In your case the 1GB video
    ram, plus another .25GB, seems to be sitting right below the 4GB range and
    that's why you're seeing 2.75GB.
     
    Paul Shapiro, Nov 19, 2009
    #2
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.