XP cant access Vista Drives???

Discussion in 'Windows Vista Networking' started by maviso5, Jan 31, 2007.

  1. maviso5

    maviso5 Guest

    Hi all

    I have got Vista Ultimate edition on main PC, XP home on my laptop, had
    mapped a network drive fine on the vista machine and can acess the laptop -
    no problem.

    But, when i want to acess any of the shared folders or a drive i had tried
    to map for the vista machine on my laptop i get the error "\\Dan-pc\Dan is
    not accessible, you might not have permission to use this network resource.
    Contact administrator etc.."
    Sharing is enabled on the drives, and there no password that has been set.

    Any help would be much appreciated.

    Thanks
    Dan
     
    maviso5, Jan 31, 2007
    #1
    1. Advertisements

  2. maviso5

    Kim [MS] Guest

    Dan,

    In your Vista machine, you need to give permissions to access/view shares on
    that machine. Right click on the networking icon in the tray. Then click on
    Network and Sharing Center; then adjust the settings so that Network
    Discovery and File Sharing are on.
     
    Kim [MS], Jan 31, 2007
    #2
    1. Advertisements

  3. maviso5

    Stosh1968 Guest

    I have the same exact problem as Dan. My network discovery and file sharing
    are both on, I have password protection off. I can see the shares on my
    other machine, but I get the permission error Dan described. I can go into
    Advanced Sharing, since the the other share button is grayed out, and Share
    this folder is checked, 10 users are able to access the share simultaneously,
    if I select permissions, the Everyone group is allowed full control, change
    and read rights. I can find no way to add permissions specific to my second
    PC, as nothing will allow me to view and/or add them.
     
    Stosh1968, Feb 1, 2007
    #3
  4. maviso5

    David Guest

    Same problem here. Sure hope we find a solution as next week I'll have to
    share a broadband Internet connection with my wifes computer.
     
    David, Feb 1, 2007
    #4
  5. maviso5

    AJR Guest

    One other aspect to consider with Vista - the network type designation -
    "Private" or "Public". Each provides different access and sharing
    capabilities.
     
    AJR, Feb 1, 2007
    #5
  6. maviso5

    maviso5 Guest

    I have tried both public and private settings, neither got me any joy. I glad
    (in a way) that i'm not the only one with this problem.
    My share buton is also greyed out and i only have the advance share buton
    (even tho the drives are shared)

    Hope someone can help

    Dan
     
    maviso5, Feb 1, 2007
    #6
  7. maviso5

    koze Guest

    If you go to the folder you want to share open up the security settings,
    remove the everyone account, in there add the name and account settings you
    want to let use the share. Set the permissions in there for that account,
    that should work.


    Ko.
     
    koze, Feb 1, 2007
    #7
  8. maviso5

    Kim [MS] Guest

    Folks,

    The networking team is investigating this now. As soon as we have a steady
    repro and a workaround, I'll let you know. It shouldn't be long.

    Thanks for your comments - they've been helpful.

    We might come back and ask for some network logs. Let me know if you're
    willing to run some and send them in for debugging purposes.

    Thanks again
     
    Kim [MS], Feb 1, 2007
    #8
  9. maviso5

    Kim [MS] Guest

    Folks,

    It would be very helpful if all who are experiencing this problem could work
    through the steps contained in this Technet article written expressly for
    this scenario. The problem may be in the Workgroup name.

    http://www.microsoft.com/technet/network/evaluate/vista_fp.mspx

    Please let us know if this solves the drive access issue.

    Thanks
     
    Kim [MS], Feb 2, 2007
    #9
  10. maviso5

    BrianHann Guest

    I have a similar problem to those descibed in this thread except I have
    created a dual boot so that I can still acccess those programmes that aren't
    yet Vista Compliant. I have the additional problem that I can't access the
    applications that reside on my XP Tablet partition, it says 'this prgramme
    has not been installed for this user, please run setup ...'

    I would rather not have to install 2 copies of Office as on a Laptop, space
    is a premium
     
    BrianHann, Feb 2, 2007
    #10
  11. Hello Kim,

    I have tried this between Vista Ultimate and XP Media Center and I'm having
    the same problem. I can sucessfully connect to a shared folder, but not a
    shared drive without getting an Access Denied error message. Password
    protecting sharing is also turned off on the Vista Ultimate machine. I also
    tried executing the command, "net user account" to ensure the account was
    active, as described in KB 308007.

    It is unlikely a workgroup name that is causing the problem, as Windows can
    support multiple workgroup names. I would be willing to sumbit any logs to
    diagose the issue.
     
    Eric Cross [MVP], Feb 2, 2007
    #11
  12. maviso5

    maviso5 Guest

    Hey hey, seems i really started something here.
    Dont blame you brian i have also dual booted saves a lot of hassle...
    And as Eric said i have that same problem! I can access shared
    folders...piece of cake, but you try mapping a network drive and it sticks
    two fingers up and you and says be an administrator etc etc...


    I would dearly love to hear an answer from anyone (includin someone from
    microsoft *hint*)

    Many thanks.......Lets hope it gets sorted....


    Dan
     
    maviso5, Feb 2, 2007
    #12
  13. maviso5

    Kim [MS] Guest

    Dan,

    I can assure you that you all have the Windows Consumer Networking team's
    attention. I work on that team. We're sorry you're experiencing trouble.
    We're working right along with you all trying to understand the issue better.


    What happens if you log in under an administrator account and approve the
    action? Do you still have the same problem?
     
    Kim [MS], Feb 2, 2007
    #13
  14. maviso5

    maviso5 Guest

    Nope
    Thats what my main account is....admin, bu it still falls over on me :(
     
    maviso5, Feb 2, 2007
    #14
  15. maviso5

    Kim [MS] Guest

    Dan,

    In a more recent post, folks have found that turning off or uninstalling
    their firewalls helps solve the problem; or if they're running OneCare, they
    change the following setting:

    Windows Live OneCare ->
    Change OneCare Settinge ->
    Firewall connection tool ->
    Tick relevant options (Network discovery, file and print settings,
    etc) ->
    OK ->
    Advanced Settings ->
    Change file sharing from 'Do not share files and printers" ->
    OK ->
    OK

    My thanks to Tom for this!

    K
     
    Kim [MS], Feb 3, 2007
    #15
  16. maviso5

    boe Guest

    I realize this is a newbie response but I'm not clear on hidden file shares.

    Typicall from my XP to XP machines I'll type \\192.168.1.x\c$ and I'll get a
    logon and password prompt and boom - I've got access to what I want.
    I can still do this from my Vista Ultimate to Windows XP Pro but I can't
    figure out how to get it to work from Windows XP to Vista

    I can go \\192.168.1.x from my XP to Vista machine and it will prompt me for
    a username and password and then show me that I have nothing being shared
    However if I go \\192.168.1.x\c$ from my XP to Vista machine it will prompt
    but never let me in.
     
    boe, Feb 3, 2007
    #16
  17. maviso5

    maviso5 Guest

    No, at the moment i am only using windows firewal on both pc's so there's no
    interference or conflict.


    Dan
     
    maviso5, Feb 3, 2007
    #17
  18. maviso5

    hydro1956 Guest

    Having sharing allowed and all the other required share/network settings
    correct in Vista and XP machines I could not access Vista shared
    foldews/printers from XP machines, however vice-versa I could. Now, after
    three days I found the solution:

    My Visata machine came with McAfee antivirus preloaded. Both the Windows and
    McAfee firewalls were on. As soon as I disabled the McAfee firewall the
    network sharing worked as intended!

    Doing a little follow-up research, I then turned off Windows firewall and
    re-enabled the McAfee firewall, as well as changed the security level setting
    in McAfee. At this point I was back to the "no-access" problem so I disabled
    McAfee firewall and re-enabled Windows firewall. The network worked like a
    carm once again. Now I assume there is an exception check box like "Allow
    network folder/pinter sharing" in McAfee's firewall like there is in windows
    firewall if you are wanting to use McAfee's firewall instead. Also, this may
    be the same issue if you have some other another firewall enabled.
     
    hydro1956, Feb 3, 2007
    #18
  19. maviso5

    maviso5 Guest

    No! that's just it, I'm using windows firewall and windows firewall ONLY!

    I use Avast as my AV software on both PC's.....so why am I getting a
    problem..Microsoft????


    Any help.Much Appreciated, as I'm starting to lose it lol

    Dan
     
    maviso5, Feb 4, 2007
    #19
  20. maviso5

    maviso5 Guest

    OK so wot u said worked...but i want to be able to share the WHOLE drive as I
    always could with XP...any ideas?

    Thanks
    Dan
     
    maviso5, Feb 5, 2007
    #20
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.