XP desktop printer networked to VISTA laptop - adding printer error

Discussion in 'Windows Vista Printing / Faxing / Scanning' started by Patrycja, Apr 18, 2008.

  1. Patrycja

    Patrycja Guest

    I recently purchased a laptop with VISTA HOME PREM. I have an XP desktop
    which is connected to my printer HP

    I have 2 other computers at home, one desktop and one laptop, who can gain
    access to the printer.

    I tried adding the printer to the laptop, the disk for the hp printer is not
    compatible with vista, and I went to HP's website and no drivers are
    available, as they suggest simply hooking up the printer to laptop. I did
    this, but I can't have the laptop always connected to the printer via cable.

    I found the the printer on the main computer network, it shows as ready,
    every time I click on the network for the lap top and choose add a printer
    it states: YOU DON'T HAVE SUFFICIENT RIGHTS TO PERFORM THIS OPERATION.

    When I go thru the control panel to add a printer with the wizard, the
    printer I want shows up, it states that it is connecting to the desktop
    printer, but then I get a message: WINDOWS CANNOT CONNECT TO THE PRINTER.
    ACCESS IS DENIED.

    How do I remedy this?
     
    Patrycja, Apr 18, 2008
    #1
    1. Advertisements

  2. Patrycja

    Patrick C Guest

    If you go to control panel and select classic view, then select printers,
    right click on the blank space below the displayed printers select run as
    administrator, select add printer, local printer, can you find the printer
    in the list?

    When I did a Google search on sharing an XP printer from a Vista PC I found
    the following and it worked for me. You have to enable printer sharing in
    the XP computer for the printer by going to control panel, printers, right
    click, properties, sharing tab, make note of the computer name and printer
    name. Then;

    " Go to Control Panel. Choose printer. Then choose Add Printer.

    ChooseAdd a local printer. Click on Create a new port. The default in the
    drop down box is Local Port. Do not change that. Click Next.

    A dialogue box will appear asking for you to enter a port name. Type in the
    \\computer name\printer name ie. My computer's name is basement and the
    printer name is EpsonSty so I typed in \\basement\epsonsty"
     
    Patrick C, Apr 19, 2008
    #2
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.