XP print jobs on vista sit in spooler

Discussion in 'Windows Vista Printing / Faxing / Scanning' started by Matt, Nov 24, 2007.

  1. Matt

    Matt Guest

    I have an HP 1020 laserjet shared out on a vista ultimate system. I can see
    the printer from an XP system (in the same workgroup), connect to it, print
    to it, but the job never prints. It sits in the spooler. If I cycle the
    spooler service, it prints when the service restarts.

    I can print local jobs fine from the vista system (TSed into it), just not
    jobs from the XP system. I've made sure that I have the latest drivers
    installed on both systems.

    Any ideas on how I can further narrow this down and fix it?
     
    Matt, Nov 24, 2007
    #1
    1. Advertisements

  2. I suspect that the print job requires access in the XP users context and
    does not have access to a resource in Vista or due to the remote context.
    When you restart the spooler service, the print job is restarted in full
    admin context since the token from the client is no longer valid for the job
    and the system admin account has access to whatever the resource required
    from the driver.

    Are there any system eventlog entries on the Vista machine when the XP
    machine submits the job?

    Does the job come in as Guest?



    --
    Alan Morris
    Windows Printing Team
    Search the Microsoft Knowledge Base here:
    http://support.microsoft.com/default.aspx?scid=fh;[ln];kbhowto

    This posting is provided "AS IS" with no warranties, and confers no rights.
     
    Alan Morris [MSFT], Nov 26, 2007
    #2
    1. Advertisements

  3. Matt

    timandtiff Guest

    I'm having this same issue with the HP Laerjet 1020. Installed on
    Vista, shared to an XP. When XP prints, the job sits in the Vista
    spooler until the spooler service is restarted, then it prints. I
    don't know how to see if the job is coming in as guest. Matt - did
    you resolve this issue? Any other ideas, Alan?

    --T
     
    timandtiff, Dec 26, 2007
    #3
  4. Matt

    astaykov Guest

    Hello,
    I have the very same issue!
    The print job from XP somec with a user which exists on the VISTA. It is
    because I first login to the vista using SMB protocol so I have an
    established security context with VISTA credential. But the print document
    from XP still stays in the queue until restart of Print Spooler. Also I have
    added the named user with full permissions in the security tab of the printer
    properties.

    Any suggestions are welcome.

     
    astaykov, Jan 3, 2008
    #4
  5. You will need to contact HP to determine which resource needs to be enabled
    for guest or the standard user account

    --
    Alan Morris
    Windows Printing Team
    Search the Microsoft Knowledge Base here:
    http://support.microsoft.com/search/?adv=1

    This posting is provided "AS IS" with no warranties, and confers no rights.

     
    Alan Morris [MSFT], Jan 4, 2008
    #5
  6. Matt

    astaykov Guest

    Hi,
    Together with the Microsoft TechNet team from the MS Forums we found a
    solution.
    The full version is posted here:
    http://forums.microsoft.com/TechNet/ShowPost.aspx?PostID=2629862&SiteID=17

    In brief: there are some local policies which should be set.
    And disable the "bidirectional support" at the "Ports" tab of the printer
    properties.

    Regards,
    Anton

     
    astaykov, Jan 5, 2008
    #6
  7. Matt

    sabbycat7 Guest

    Hi,
    After trying to work out where the local policies were to check them (still
    don't know and doesn't matter to me now), I disabled the "bidirectional
    support" at the "ports" tab of the printer as my first step... and hey
    presto! both XP machines are now printing to the Vista printer!
    Thank you
    Mari
     
    sabbycat7, Jan 28, 2008
    #7
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.