XP Pro problems with DEP

Discussion in 'Windows 64 Bit' started by poulter90, Nov 22, 2006.

  1. poulter90

    poulter90 Guest

    Hi all , just a few details about my situation :

    1) Specifications of my PC listed by AIDA 32 v3.93
    Acer 5633WLMI version 2.80 XP service pack SP2 , Media Center Edition
    2005
    Multi CPU T5500 1.66 Ghz , 1662 MHZ
    Memory /M1
    SODIMM Synchronous 512 MO , size 32 bits
    Memory/M2
    SODIMM Synchronous 512 MO, size 32 bits

    Physical Memory
    Total 1022 MO
    Used 462 MO
    Available 559 MO
    Usage 45%

    Swap zone
    Total 923 MO
    Used 387 MO
    Available 535 MO
    Usage 42%

    Virtual memory
    Total 1945 MO
    Used 849 MO
    Available 1095 MO
    Usage 44%

    BIOS type Phoenix
    System BIOS date 09/01/06
    Video BIOS date 08/30/06

    2) I red in the documentation
    (http://msdn2.microsoft.com/en-us/library/ms791539(d=printer).aspx

    The /noexecute parameter is effective only on 32-bit-processes.It enables
    software enforced DEP and,if the processor supports DEP,it also enables
    hardware-enforced DEP.
    On 64-bit processes,DEP is enabled by default and cannot be disabled
    (equivalent to /noexecute=AlwaysOn).For these processes, the /noexecute
    parameter is ignored.On a 64-bit operating system,the /noexecute parameter
    affects only 32-bit processes running on the system .

    Question is :
    Having 2 memory SODIMM 32 bits each ,does it mean I am running 64-bit ?
    If yes , even if I want to turn off the DEP , I CANNOT as explained above !!!

    I tried to turn off DEP (/noexecute=AlwaysOff) but I am still receiving
    messages informing that whatever programs or applications . exe has problem
    and need to be closed . I think this PC is crap and I think I will never
    get rid of this bug , I have to send it back to reseller !

    Any genious ideas ????
     
    poulter90, Nov 22, 2006
    #1
    1. Advertisements

  2. poulter90

    John Barnes Guest

    Hopefully your question will make sense to someone, but you turn DEP off or
    on in system properties / advanced / performance / Data Execution
    Prevention
     
    John Barnes, Nov 22, 2006
    #2
    1. Advertisements

  3. I don't know, John - My HP Notebook is 64bit and I have had major head-aches
    about some processes refusing to pass on execution via some DLL or other, I
    am not allowed to disable DEP, (alternatively: have not found a way) which
    wrinkles my ass.

    Tony. . .
     
    Tony Sperling, Nov 22, 2006
    #3
  4. poulter90

    John Barnes Guest

    Have you checked the alternate box and entered the program you are having a
    problem with. I have had to do it with some Roxio programs. Ultimately, it
    would be up to any restrictions of the system or os if there are any.
     
    John Barnes, Nov 22, 2006
    #4
  5. It's been a while, now. Don't remember all I've tried - I think I even had
    it ship off a message to MS about it, but I will check that!

    Thanks.

    Tony. . .
     
    Tony Sperling, Nov 22, 2006
    #5
  6. poulter90

    John Barnes Guest

    I had to check the selection "turn on DEP for all programs and services
    except those I select" and then enter the appropriate program. I am in
    Vista now, where I can't install Roxio anyway. In fact since the drivers
    weren't signed, when it got to that point, when I selected to cancel, it
    made all my CD/DVD drives invisible and required a full install since no one
    proffered a less drastic solution. At least now I have it installed on two
    partitions and use one to make sure anything I try works, before installing
    it on the one I try to use regularly.
     
    John Barnes, Nov 22, 2006
    #6
  7. Ah, well - that I could have missed. Turn'em off one-by-one!

    Yes, now that you're saying it, I could believe that.


    Tony. . .
     
    Tony Sperling, Nov 22, 2006
    #7
  8. poulter90

    poulter90 Guest

    Related to this documentation , it seems to be impossible to disable DEP !!!

    (http://msdn2.microsoft.com/en-us/library/ms791539(d=printer).aspx

    The /noexecute parameter is effective only on 32-bit-processes.It enables
    software enforced DEP and,if the processor supports DEP,it also enables
    hardware-enforced DEP.
    On 64-bit processes,DEP is enabled by default and cannot be disabled
    (equivalent to /noexecute=AlwaysOn).For these processes, the /noexecute
    parameter is ignored.On a 64-bit operating system,the /noexecute parameter
    affects only 32-bit processes running on the system .

    Unless someone has already tried following option in BOOT.IN file ???
    /noexecute=AlwaysOff /nopae or
    /noexecute=AlwaysOff / pae

    ???????????????
     
    poulter90, Nov 23, 2006
    #8
  9. poulter90

    Jane C Guest

    I wouldn't let this worry you. You are running a 32 bit operating system.
    All processes on your computer are 32 bit. Your 2 SODIMMS at 32 bits each
    do not make anything run at 64 bit.
     
    Jane C, Nov 23, 2006
    #9
  10. poulter90

    poulter90 Guest

    Thanks Jane , although I cannot get rid of this DEP problem , I am pleased I
    can try using several options in the BOOT.INI file to solve it .

    Could be a malware on my memory stick !
     
    poulter90, Nov 23, 2006
    #10
  11. Do note what John said back there - you may not be able to turn DEP off, but
    you should be able to disable it for specific applications if you provide a
    name for it to deal with!

    Tony. . .
     
    Tony Sperling, Nov 23, 2006
    #11
  12. poulter90

    John Barnes Guest

    Thanks Tony. I'm in X-64 and you follow the instructions I gave above,
    click on add and browse to the problem executable. Click okay when you find
    it and the problem is over for that one.
     
    John Barnes, Nov 23, 2006
    #12
  13. Thank YOU! I can see my self thoroughly enjoying getting rid of these little
    'buggers'!


    Tony. . .
     
    Tony Sperling, Nov 23, 2006
    #13
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.