XP Service Pack 2 blocks my local ActiveX controls

Discussion in 'Windows Update' started by Giordano, Nov 15, 2004.

  1. Giordano

    Giordano Guest

    While I develop and test ActiveX controls local on my system, whenever
    I attempt to bring up the .html page to view my updates, I get the
    message

    "Your security settings do not allow Web sites to use ActiveX controls
    installed on your computer. This page may not display correctly,
    Click here for options..."

    Then when I step through the help instructions to change my settings
    to allow ActiveX content, that doesn't work. I've also read through
    the groups for about 2 days now to notice that no one seems to know
    how to turn this annoying bar off. There are alot of frustrated
    developers out there because of this SP, me being one of them. I have
    reccomended to the rest of my company that we not upgrade to SP2
    because of these issues. We develop applications for military
    training and our customer's do not want to see things get more
    difficult to use. The only thing I saw that remotely helped was to
    change the zones in the registry for ActiveX content and then rename
    the .html files to .hta files. This is hardly a deliverable solution
    to a customer for us.

    If ANYONE out there has any clue how to turn this thing off
    permanently, please feel free to speak up. Any assistance would be
    greatly appreciated. OR any information on what might happen if I
    uninstall the SP2 update would be helpful as well. I can see that
    screwing up my system as well. Thanks.
     
    Giordano, Nov 15, 2004
    #1
    1. Advertisements

  2. Giordano

    Taurarian Guest

    Taurarian, Nov 16, 2004
    #2
    1. Advertisements

  3. Giordano

    Giordano Guest

    Thanks for your comment. I already found that document (I believe it
    was Ramesh that posted it) This does not work. The only way I can
    get an ActiveX control to display on a local system is to change Zone
    settings in my registry then change my .html to a .hta file type.
    Unfortunately, this is not a deliverable solution. Thanks.
     
    Giordano, Nov 16, 2004
    #3
  4. Giordano

    Ramesh [MVP] Guest

    Hi Giordano,

    Have you tried the "Mark of the Web" workaround as described in the Developer Implications page?

    --
    Ramesh, Microsoft MVP
    Windows XP Shell/User
    http://windowsxp.mvps.org

    Thanks for your comment. I already found that document (I believe it
    was Ramesh that posted it) This does not work. The only way I can
    get an ActiveX control to display on a local system is to change Zone
    settings in my registry then change my .html to a .hta file type.
    Unfortunately, this is not a deliverable solution. Thanks.
     
    Ramesh [MVP], Nov 17, 2004
    #4
  5. Giordano

    Giordano Guest

    I have not. Can you point me to where that example resides? Thanks.
     
    Giordano, Nov 29, 2004
    #5
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.