XP-VISTA Ultimate upgrade UAC Problem

Discussion in 'Windows Vista Security' started by Dan, Dec 20, 2008.

  1. Dan

    Dan Guest

    I have upgraded a XP machine (domain member) to Vista Ultimate (domain
    member) and am having problems running system utilities that require
    administrate or elevated rights. I think it is an issue with UAC / security.

    With UAC enabled many programs in the c:\windows\system32 will not run and
    return the "path does not exist" error that I show below when I would be
    expecting the UAC prompt.

    An example includes: Control Panel -> System -> (under tasks)
    Remote settings, System protection, and Advanced system settings all fail
    with the following error:

    C:\Windows\system32\systempropertiesprotection.exe
    The specified path does not exist.
    Check the path, and then try again.

    If I navigate to the file and double click it, same error. All of the
    SystemPropertiesXXXXX exe files fail to run and give the error above.

    If I right click on the file and select Run as administrator, I get the UAC
    prompt and it works fine.

    With UAC disabled all files run correctly.

    The Device Manager Task in the System area of control panel works correctly
    in all cases (UAC prompt).

    Another example is changing the firewall settings: Control Panel -> Security
    Center -> Windows Firewall -> Change Settings fails the same way as above
    except the file is C:\Windows\system32\firewallSettings.exe

    Adding the user to the local administrator's group changes the UAC behavior
    as expected (prompt for consent, versus prompt for credentials), but does
    not change the problem behavior.

    This machine has the full Office 2007 suite installed++ (Visio, Project,
    Adobe) and I really don't want to do a clean install. The system is well
    behaved in all other areas. This problem is consistent.

    I have unloaded the Trend AV solution, disabled the MS firewall, deleted and
    recreated the user profile, all with no change in the system behavior.

    This problem appears similar to the problem of running programs that require
    elevated permissions from a mapped network drive, except this is my local
    hard drive. Any ideas on how to fix this without a wipe of the machine?

    Thanks!
     
    Dan, Dec 20, 2008
    #1
    1. Advertisements

  2. Dan

    Jim Guest

    Before you upgraded , did you find out if your system was compatible ?
     
    Jim, Dec 20, 2008
    #2
    1. Advertisements

  3. Dan

    Dan Guest

    I ran the dell and ms upgrade advisor programs before the upgrade and all
    sw/hw was compatible. There was a minor issue with an audio driver, which I
    upgraded with a vista driver after the upgrade.

    The upgrade process was clean, no errors during the process.
     
    Dan, Dec 20, 2008
    #3
  4. Dan

    Mark H Guest

    Attempt to perform a Repair System from the Installation DVD.

    Should that fail,
    Attempt to turn off System Restore on all drives, then turn it back on.
    (This will erase all restore points.)

    Should that fail,
    Attempt to turn off System Restore on all drives, run sfc/scannow from an
    elevated prompt.
    (You may need to have the Vista install disk inserted.)
    Then, turn System Restore back on.
     
    Mark H, Dec 21, 2008
    #4
  5. Dan

    Dan Guest

    Performed all of the steps suggested with no changes in system behavior and
    no errors found during either the repair and the sfc scan. I then upgraded
    (from Ultimate to Ultimate) and after activating the SW everything worked!
    I rebooted and the behavior returned. Appears to be associated with the
    activation process. Cross posting to setup group.

    Anyone have any more ideas?
     
    Dan, Dec 23, 2008
    #5
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.