"You do not have the proper encryption level to access this Sessio

Discussion in 'Server Networking' started by FloridaBum, Jul 31, 2005.

  1. FloridaBum

    FloridaBum Guest

    I had the following problem, and I found the solution:

    Had Windows Server 2003 running. Installed SP1. Lost RDP connectivity with
    the error message "You do not have the proper encryption level to access this
    Session" being returned to the client.

    Solution:

    It seems that SP1 didn't properly handle the existing connection that was
    configured under Terminal Services Configurations (tscc.msc /s). I ended up
    deleting the RDP connection and re-creating it.

    Before doing this, I found a post that said I should set the following
    registry key:

    HKLM/System/CurrentControlSet/Control/Terminal
    SErver/WinStations/RDP-TCP/MinEncryptionLevel

    to 0. I did this with no effect. I also set MaxConnectionTime from
    5265c00 hex (86400000 decimal) to c00 hex. I just guessed at this c00 value
    - I was trying to time-out any sessions that might be in effect (after all,
    the message said "You do not have the proper encryption level TO ACCESS THIS
    SESSION"). Of course, I rebooted between each change. After I got the new
    connection working, these two key values were already cleared - no need to
    reset them.

    I hope this helps other people!
     
    FloridaBum, Jul 31, 2005
    #1
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.