You have been denied permission to access...

Discussion in 'Windows Vista Administration' started by P Huebner, Nov 15, 2006.

  1. P Huebner

    P Huebner Guest

    While dualbooting XP SP2 and Vista RC2 i have an annoying problem.

    - "You have been denied permission to access this folder."
    - "Photo Gallery can't open this picture because you do not have permission
    to access the file location."
    - "Cannot open file.xxx"
    All these happen when i am trying to create, download, install or whatever
    in XP and open the files in Vista.

    I know I can change the ownership, file permission in security tab, but i
    CANNOT give permission to multiple files in Vista at once (but it is possible
    in XP). UAC is off. I honestly don't want to edit every single file
    permission by myself.

    So i am asking if anyone has the same problem in working with both OS or if
    theres any solution of how i can fix this?
     
    P Huebner, Nov 15, 2006
    #1
    1. Advertisements

  2. P Huebner

    Jimmy Brush Guest

    Hello,

    The solution is NOT to change ownership; rather, you need to add a
    permission in Vista via the security tab to the folder where these files
    resides that gives your username read/write access. The permission applied
    to the folder will automatically apply to all the files that you created
    inside of that folder.
     
    Jimmy Brush, Nov 17, 2006
    #2
    1. Advertisements

  3. P Huebner

    P Huebner Guest

    when i first try just to add permission it says i am not authorized to access
    the file. because i do not own it. and in the ownership tab it says 'unable
    to determine ownership', thats why i ave to set ownership first before
    adding a permissions for everything.

    and no, it does not work either, when i try to allow access a folder
    including their subfolders and files at once. i will get 'permission denied'
    for all the folders and files inside it. thats why i have to change every
    single file by myself.
     
    P Huebner, Nov 17, 2006
    #3
  4. P Huebner

    Jimmy Brush Guest

    when i first try just to add permission it says i am not authorized to
    Just to make sure we are on the same page - you are attempting to modify
    security on files that you created from another OS, and not system files?
    Have you modified the permissions on these files from the other OS? This
    behavior should only occur if Administrators are not allowed to edit
    permissions on the file, which shouldn't happen.
    Sounds like your files are set up so that administrators have no access to
    them. Your best bet is to use the takeown command-line tool to work your way
    through the folder tree. Make sure you give the administrators group
    ownership of the files and not your specific username in Vista, as this will
    decrease the chance of having problems accessing the files outside of Vista.

    Once you have ownership of all the files, you should be able to change the
    permissions at the top-level folders and they should propogate correctly.

    You will need to use an elevated command prompt in order to use the takeown
    command-line utility. Right-click command prompt in the start menu and click
    Run As Administrator.

    Example command-line:

    takeown /F . /A /R

    Will take ownership of everything inside of the current folder, including
    all nested subfolders and files, and assign the owner to the administrators
    group.
     
    Jimmy Brush, Nov 17, 2006
    #4
  5. I have the same problem. I installed Vista on a new partition. It can access
    all the XP files and folders in other drives but they are all read only. I
    changed ownership to mymachine\administrators for all the files & folders in
    those drives. That did not fix the issue.

    I noticed that all folders and files have read only attribute. I reset the
    attribute for all of them but as soon as I click OK to click the dialog box
    and go back to check it, I see that they still have Readonly attribute.
     
    Adil Hindistan, Nov 18, 2006
    #5
  6. P Huebner

    Jimmy Brush Guest

    Hello,

    Changing ownership does Not give you access to the files. Changing ownership
    only allows you to edit permissions on the files. The reason I recommended to
    the OP here to change ownership was because he could not change the
    permissions any other way.

    Changing ownership on files is not recommened unless you are having problems
    changing permissions.

    You still must give yourself permission to access those files in Vista. Find
    the folder that contains the files you need access to (such as My Documents,
    My Pictures, or a folder that you created) This will not work on system
    folders such as Windows or Documents and Settings.

    - Open an explorer window
    - Find the folder you need access to
    - Right-click it
    - Click Properties
    - Click the Security Tab
    - Click Edit
    - Click Add
    - Type your username and press enter.
    - Click the checkbox under Allow next to Full Control
    - Click OK
    - Click OK

    - JB
     
    Jimmy Brush, Nov 18, 2006
    #6
  7. Thanks Jimmy. I did not have time to look at the issue deeper before posting.
    I guess many people will have this situation and may be puzzled by the fact
    that although their user account is added to "administrators" group by
    default and administrators group has full access to all files and folders in
    their systems, they will still see "access denied"...

    I am not sure if this partly because users who are part of administrators
    groups are not in fact regular users most of the time and automagically
    become admins when there is a need for elevated rights. It has the same idea
    implemented at Ubuntu but does not ask for password by default (could be
    modified to do so editing secpol.msc)

    Anyway that's not related to the issue. To resolve my problem, I've created
    a local group and added both my account and my wife's account to it. As
    simply adding this group at the drive level would not help and I needed to
    force it down so that all the changes are inherited,
    * I made the new group owner of all files and folders
    * In the drive securities dialog box, added the new group and granted Full
    rights
    * In the same dialog box Clicked Edit > Advanced and checked "Replace all
    existing inheritable permissions on all descendants with inheritable
    permissions from this object"
    * Logged off, logged back in & there I got full access to all my XP drives...
     
    Adil Hindistan, Nov 19, 2006
    #7
  8. P Huebner

    Jimmy Brush Guest

    As
    It would have been better to have modified the permissions of the folders
    that directly contain the files you need access to by adding a single
    permission entry granting access to your specific username in vista. This
    would not have required any advanced "forcing" options, as the files inside
    the folder would automatically inherit the permissions of their parent
    folder.

    Changing permissions on a drive and then forcing propogation is generally
    considered a bad idea. You are wanting to ADD permissions to files/folders
    while leaving the default security in place; this is a destructive operation
    that replaces permissions, weaking the security of your system and possibly
    causing undesirable side effects.
    This may cause some problems if you boot back into XP - its generally best
    to leave ownership alone, unless there is no other way to change the
    permissions you wish to change.

    Regardless, I'm glad you got it working :)
     
    Jimmy Brush, Nov 19, 2006
    #8
  9. P Huebner

    Jimmy Brush Guest

    It would have been better to have modified the permissions of the folders
    Replace YOUR SPECIFIC USERNAME here with the user group you created. :)
     
    Jimmy Brush, Nov 19, 2006
    #9
  10. I have replied to you twice but I found myself back on this screen and my
    answer was gone. I am trying one last time...

    The reason I forced it down was because the new group I added was not
    inherited by the files & folders below.

    XP on the other hand worked just find although naturally could not enumerate
    the new group. So both are happy now.
     
    Adil Hindistan, Nov 20, 2006
    #10
  11. P Huebner

    Jimmy Brush Guest

    Hello,

    When I was first introduced to Windows NT many moons ago I did the same
    thing myself ... except I ended up locking everyone (including SYSTEM) out
    of my entire disk drive, even after multiple warnings from Windows about how
    that wasn't such a good idea. lol. Needless to say, the system wouldn't boot
    and I ended up reformatting.

    Anyway, based on what you've said, it sounds like you added a DENY
    permission. Deny permissions override any other ALLOW permissions on the
    file.

    Example: allowing the Administrators group access to a file and then DENYing
    the users group access to that file.

    This would seem to block normal users but allow administrators access, but
    that's not what happens. Since deny permissions take precedence, both
    administrators and users are denied access, since all administrators are
    users and users are denied.

    Most of the time you should never need to set a deny permission. If you do,
    DON'T deny access to a file to a well-known group (such as users or
    administrators) - set deny permissions on a single user account or create a
    new group (such as "blocked users") and put that group in the deny
    permissions.

    In this case, you will need to take ownership of the files in order to be
    able to change their permissions.

    Following these steps should allow you to change the permissions on the
    files:

    1) open admin command prompt

    - Click start
    - Type: cmd
    - right-click it under programs
    - click Run As Administrator

    2) take ownership of everything

    - browse to the folder that you need access to
    (for example, "cd c:\users\jimmy\documents\folder")

    In the command prompt, type:
    takeown /F . /A /R /D Y

    and press enter.

    3) change permissions

    You should now be able to remove the deny permissions and make any other
    changes, and then have those changes propogated down the folder heirarchy.
     
    Jimmy Brush, Dec 23, 2006
    #11
  12. P Huebner

    Faycal Guest

    thx man very helpful
     
    Faycal, Dec 23, 2006
    #12
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.