"you need permission to perform this action" copying a file

Discussion in 'Windows Vista Security' started by karlid, Nov 21, 2007.

  1. karlid

    karlid Guest

    It's almost embarressing to ask this but I need help copying a file
    from a network share to my Vista computer. For some reason I am
    completely blocked when attempting this.

    Here's the situation:

    * 3 gb ISO on a networked-pc (running XP) file share with read
    permissions. i can see the file in Windows Explorer after providing
    network login credentials.
    * when attempting to copy to any folder on my Vista Home computer
    (tried desktop, c: root, and 'downloads') I am denied with a error:
    "you need permission to perform this action"
    * I've read various other posts on the matter which all point to
    ownership issues. I have taken ownership over the local folder and it
    makes no difference
    * Initially I had ACL turned off but have since reactivated it to see
    if that helped. It did not.
    * I log in with a local user to Vista but use the same username (with
    different password) when connecting to the network.

    What the heck do I need to do to copy a file off the network??

    Any help is mucho appreciated.
     
    karlid, Nov 21, 2007
    #1
    1. Advertisements

  2. karlid

    karlid Guest

    The problem was that the network permissions were set to 'list' but
    not 'read'. Apparently, I was barking up the wrong tree with the
    permissions on the Vista side. The new error dialog through me off.
     
    karlid, Nov 21, 2007
    #2
    1. Advertisements

  3. karlid

    MadMax Guest

    Hi Karlid,

    This might be the answer I'm looking for.

    I'm logged into Vista as the administrator (only the one account was setup
    during install).

    Anyway, for the first time since installing Vista, I decided to connect my
    7-in-1 card reader and empty my flash card from my digital camera as there
    were some photos I wanted to send.

    Vista recognised it as a "USB 2.0 Card Reader" but doesn't have any drivers
    loaded for it so I can't access the photos. Tried asking it to update the
    driver, giving it permission to go on-line. No luck.

    So I then stuck the card reader into my Ubuntu box and copied the photos to
    a directory called "Photos" and then to a sub-directory called "Max" (for the
    photos from my camera) and a sub-directory called "Lesley" (for the photos
    from my wife's camera).

    I then went back to my Windows machine and found this directory (Photos) in
    my mapped network drives and tried to copy it (not move it) to the Vista
    desktop. This bought up a dialogue box saying "You need permission to perform
    this action", along with the name of the file. The only options are "Try
    again" (which fails), "Skip" (which defeats my purpose) or "Cancel" (the only
    thing left).

    I then thought it might be something to do with Vista protecting the desktop
    so I tried copying it to a directory within my Documents but had the same
    lack of success.

    I then thought I might be still be able to email the photo, so I tried to
    attach a photo by navigating to the network drive and selecting my photo but
    that didn't work either.

    Why won't Vista let me copy files from a network drive? Oh, and does anyone
    know what I can do regarding a driver for my generic 7-in-1 card reader that
    it recognises as such but can't find it's own driver for?

    Thanks in advance.

    Additional info

    I just went to the network drive and tried to copy just a photo by itself.
    No luck. Then double-clicked on it (as it was listing the files by name) to
    view the photo and Windows Photo Gallery opened with a message saying "Photo
    Gallery can't open this picture because you don't have permission to access
    the file location." - And yet Vista allows me to navigate in Explorer to see
    the files within that directory, so it does let me access that file location.
    Confused.
     
    MadMax, Jan 10, 2008
    #3
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.