"You need permission to perform this action"

Discussion in 'Windows Vista Administration' started by Tryin_to_Learn, Jun 19, 2007.

  1. I'm so frustrated. I'm trying to do such simple things -- I transfer a file
    from my external harddrive to my new computer. Then I try to rename it or
    delete it and get the "You need permission" run-around. I'm the only user of
    this machine and it's an administrator account so it makes no sense to me.
    Then with another folder, I renamed it and all went well. Then I tried to
    rename it a second time and got the "You need permission" message. I had just
    renamed it! How can it give me permission once and deny permission the second
    time? I've looked through some of the other posts with similar problems and I
    see suggestions about command line executions and stuff and yeah, if that's
    what I have to do, I'll do it. But it seems like something is seriously wrong
    with this program to be so hard for the typical user (i.e., non-IT person).

    So, after my brief rant . . . anyone have ideas what I need to do here? One
    thing I'm concerned about . . . I bought this computer as a display model.
    The computer name (core admin account) was set to "Best Buy". (Guess where I
    bought the computer <g>.) Anyway, I took it back, told them I didn't want my
    computer named Best Buy and that I hadn't been able to rename it. They ended
    up creating a new admin account, transferring all the files to that, and then
    deleting the Best Buy account. Could that be part of why I'm having trouble?

    Help?
     
    Tryin_to_Learn, Jun 19, 2007
    #1
    1. Advertisements

  2. Tryin_to_Learn

    Jimmy Brush Guest

    Hello,

    The prompts are meant to protect system locations (such as program files
    and c:\) from non-administrative access.

    You should not be experiencing any prompting when accessing files inside
    of your user folder (such as Documents, Pictures, etc) or folders that
    you have created in Windows Vista.

    You may have to go through a prompt to access folders or files from
    other hard drives.

    You can change the security settings on folders and files to stop them
    from prompting, but you should only do this on folders that you created
    or only contain files that you will create, you should never do that on
    system folders.

    Can you be more specific as to what version of Windows Vista you have
    and what locations are prompting you for permission?
     
    Jimmy Brush, Jun 19, 2007
    #2
    1. Advertisements

  3. I'm on Windows Vista Home Premium and the files I was trying to change were
    all in the Documents folder in my user folder.
     
    Tryin_to_Learn, Jun 19, 2007
    #3
  4. Tryin_to_Learn

    Jimmy Brush Guest

    See if this helps:

    - Click start
    - Type: command prompt
    - Right-click command prompt when it appears
    - Click Run As Administrator
    - Type the following commands exactly, pressing enter after each line:

    cd %userprofile%
    icacls . /grant "%username%":(OI)(CI)(F) /T /C /L /Q
     
    Jimmy Brush, Jun 19, 2007
    #4
  5. Here's an update -- I tried connecting to email support and got the error
    message that my Product ID is invalid. I even tried having Microsoft get the
    Product ID directly from my computer and it still says the ID is invalid. I
    had used the same Live Chat support a few days ago, before Best Buy deleted
    the original admin account and set this one up and I was able to get in just
    fine. Any ideas what's causing my ID to appear invalid? I'd like to be able
    to use LiveChat if I need to.

    Also, now I'm unable to replicate the problem I was having earlier. I'm no
    longer getting the "need permission" message in the Documents folder. The
    only thing I can think of is that I had tried enabling sharing of that folder
    and then rebooted my computer. Could that have fixed it?
     
    Tryin_to_Learn, Jun 19, 2007
    #5
  6. Ok -- I'm afraid I'm dense but just to be sure -- do I actually type
    userprofile? I'm thinking I do type that, but I substitute my username where
    it says username, right? Also, when I get the command prompt, it's
    automatically signed in as an administrator.
     
    Tryin_to_Learn, Jun 19, 2007
    #6
  7. Tryin_to_Learn

    Jimmy Brush Guest

    Enabling sharing may have done it, it does muck around with security
    settings.

    Not sure about the support question, considering it was fine before, but
    I have heard that in some cases you have to get support through your
    computer manufacturer and not Microsoft directly.
     
    Jimmy Brush, Jun 19, 2007
    #7
  8. Tryin_to_Learn

    Jimmy Brush Guest

    You can type those commands exactly as I typed them - those %%'d items
    are automatically filled in with the correct value by your computer.

    Or you can fille them in yourself if you'd like. %userprofile% is your
    user profile folder.
     
    Jimmy Brush, Jun 19, 2007
    #8
  9. Ok, I did what you suggested. Keep your fingers crossed.
     
    Tryin_to_Learn, Jun 19, 2007
    #9
  10. Hi,

    I am tryin to delete a file from my "programs file" that I no longer require
    and I keep getting a message saying that i do not have permission.

    I am the administrator of this computer and am the only user.

    How do I get permission so that this message will not come back on any
    folder i try to delete in the future?

    This is really frustrating and i have alot of folders which give me this
    message mainly from software created folders where i have uninstalled the
    software and wish to delete the remaining folder as it is no longer needed.

    Also some software that has been installed i wish to uninstall but once
    again i get the same message how do I solve this problem too?
     
    James Hallett, Jun 27, 2007
    #10
  11. When I tried this it told me that my username (which is did substitute for
    %username&) is an invalid parameter!
     
    Steve Woodward, Jan 21, 2008
    #11
  12. Hi,
    I've been following your thread becasue I have the same problem in
    being prompted every time I try to download certain programs, files,
    even HP updates and patches> A real pain.
    I am able to go to Control Panel in the Programs and to Change Add or
    Delete a program though> Is that where you're giong? You should be able
    to do it this way; reboot and then see what happens> Since you've been
    working on your pc I would restart it and then try the deletions and
    rebooting> I would not find this necessary on my systems but you're
    having other problems in addition> It's worth a try. If you've done it
    this way then ignore me and I appologize. Cher


    --
    Cher (BIRDWISE)

    Cher Angelo; MLS,HS,ASCP, cert grp fac, & C.A.S., cert ornithology
    Health Educator, Writer, Nature Photographer
    BIRDIWISE Avian Care Advice-MA Chronic Pain Mngmnt. Progs. - MA
    :)
     
    Cher (BIRDWISE), Jan 23, 2008
    #12
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.