Zoom and stretch modes (non-square pixels)

Discussion in 'Windows Media Center' started by jamie, Mar 31, 2005.

  1. jamie

    jamie Guest

    I'm running MCE2005 into a Pioneer plasma at 1280x768 via DVI. MCE seems to
    only understand square pixels so when watching DVDs or HDTV I get small black
    bars filling only 1280x720 (and everyone is 6% too fat on my screen).

    I'm looking for ways around this.

    The most obvious solution would be a "stretch" mode that would just fill the
    screen (in my case stretching vertically about %6). I can't seem to find that
    option. (This would also be nice for those with 42" plasmas at 1024x768
    16:9.) Anybody know a way to do this?

    I have found that with DVDs I can change the setting on the NVDVD decoder to
    "anamorphic" and then it will fill my screen vertically but will be in a 4:3
    aspect ratio (compressed horizontally). I can then select Zoom3 which fills
    the screen and everything is great.

    This does not work for HDTV though. Zoom3 seems to do nothing on HDTV
    content when using "anamorphic" in the decoder. The picture just stays 4:3
    with everyone tall and skinny. Is this a bug? If so, anyone heard that it
    would be fixed soon?

    What is Zoom3 supposed to do anyway? Seems to stretch horizontally to fill
    the screen on DVDs, but on HDTV content with the decoder set to normal mode
    (instead of anamorphic as above) it zooms instead of stretching. This gets
    rid of the small horizontal black bars that I have, but everything is still
    6% too wide.

    My fallback option is to use 1280x720 resolution RGB instead of DVI.
    However, the picture quality is not nearly as good. (Due to analog cable, and
    scaling twice instead of once.)

    Any help would be greatly appreciated!
     
    jamie, Mar 31, 2005
    #1
    1. Advertisements

  2. I have a 1280x768 widescreen TFT with square pixels here, but I, too, wish
    I could get rid of the bars when watching widescreen content...
    Believe it or not, MCE _2004_ actually had a zoom mode which stretched
    widescreen content to the full pixel size of my screen (slightly distorting
    it in my case). In fact, the zoom modes in MCE 2004 really made sense and
    were useful.

    In contrast, the MCE 2005 zoom modes are completely useless when viewing
    widescreen content on my widescreen display. There is actually a zoom mode
    fix for MCE 2005, but, unfortunately, it didn't make the slightest
    difference for me. I have no idea what Microsoft were thinking when they
    changed (or should I just say: broke) the zoom modes in MCE 2005.
    As a fix has already been released, it looks to me as if the current
    behavior is indeed intended by Microsoft. Not sure what usage scenarios
    Microsoft has in mind, but it doesn't seem to match mine or yours...

    Regards,«
     
    Robert Schlabbach, Apr 1, 2005
    #2
    1. Advertisements

  3. jamie

    Jamie Guest


    This fix actually worked for me! Thanks for the tip. I did not install the
    hotfix that's supposed to go with it, just the zoom fix. Now I run
    "anamorphic" mode in NVDVD decoder and Zoom3 properly fills the screen. Yay!
     
    Jamie, Apr 1, 2005
    #3
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.